From 436e462c6405e9bcbdd2756b596d32c763fcd7ee Mon Sep 17 00:00:00 2001
From: Marcus Folkesson <marcus.folkesson@gmail.com>
Date: Mon, 12 Feb 2024 16:04:09 +0100
Subject: python-yaml: create /host target

Make the python-yaml/host target available for the build environment
to be used with e.g. the PKG_BUILD_DEPENDS list.

This is needed for an upcoming package (libcamera).

Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
---
 lang/python/python-yaml/Makefile | 4 ++++
 1 file changed, 4 insertions(+)

(limited to 'lang')

diff --git a/lang/python/python-yaml/Makefile b/lang/python/python-yaml/Makefile
index 92ac32841..8a62c7f36 100644
--- a/lang/python/python-yaml/Makefile
+++ b/lang/python/python-yaml/Makefile
@@ -20,10 +20,13 @@ PKG_LICENSE_FILES:=LICENSE
 PKG_CPE_ID:=cpe:/a:pyyaml:pyyaml
 
 PKG_BUILD_DEPENDS:=python-cython/host
+HOST_BUILD_DEPENDS:=python-cython/host
 
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 include ../python3-package.mk
+include ../python3-host-build.mk
 
 define Package/python3-yaml
   SECTION:=lang
@@ -43,3 +46,4 @@ PYTHON3_PKG_BUILD_VARS:=PYYAML_FORCE_LIBYAML=1
 $(eval $(call Py3Package,python3-yaml))
 $(eval $(call BuildPackage,python3-yaml))
 $(eval $(call BuildPackage,python3-yaml-src))
+$(eval $(call HostBuild))
-- 
cgit v1.2.3