aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2017-03-06 09:59:18 +0200
committerGitHub <noreply@github.com>2017-03-06 09:59:18 +0200
commite6b3b33163a44152c1a1d29643b0e154b13611f4 (patch)
treeca5215328145cb46d34b48aa0e7643e332b45141 /lang
parent1604899cd430f2842510d85fedb7bc25bdd1bc8c (diff)
parent274cacf365dce1759fa725a379659bcda5f5f397 (diff)
Merge pull request #4074 from commodo/python-cryptografix-fix
python-cryptography: fix build by disabling setup requirements
Diffstat (limited to 'lang')
-rw-r--r--lang/python-cryptography/Makefile2
-rw-r--r--lang/python-cryptography/patches/001-disable-setup-requirements.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/lang/python-cryptography/Makefile b/lang/python-cryptography/Makefile
index d657089d7..9ac237d01 100644
--- a/lang/python-cryptography/Makefile
+++ b/lang/python-cryptography/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cryptography
PKG_VERSION:=1.5.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/21/e1/37fc14f9d77924e84ba0dcb88eb8352db914583af229287c6c965d66ba0d
diff --git a/lang/python-cryptography/patches/001-disable-setup-requirements.patch b/lang/python-cryptography/patches/001-disable-setup-requirements.patch
new file mode 100644
index 000000000..07ae483c2
--- /dev/null
+++ b/lang/python-cryptography/patches/001-disable-setup-requirements.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index b5c05df..a777dd7 100644
+--- a/setup.py
++++ b/setup.py
+@@ -266,6 +266,7 @@ class DummyPyTest(test):
+ with open(os.path.join(base_dir, "README.rst")) as f:
+ long_description = f.read()
+
++setup_requirements=[]
+
+ setup(
+ name=about["__title__"],