aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2017-02-26 12:28:33 +0200
committerAlexandru Ardelean <alexandru.ardelean@riverbed.com>2017-02-26 12:38:21 +0200
commit274cacf365dce1759fa725a379659bcda5f5f397 (patch)
treedb721cf4931f525689efce023109fc8e04aa0a38 /lang
parent4bceecac96cd48da65a35c5a2fc67f380de3d3d3 (diff)
python-cryptography: fix build by disabling setup requirements
python-cryptography tries to install other packages during setup. However, this isn't needed, since they should have been already resolved/installed via LEDE/OpenWrt's build system dep logic. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python-cryptography/Makefile2
-rw-r--r--lang/python-cryptography/patches/001-disable-setup-requirements.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/lang/python-cryptography/Makefile b/lang/python-cryptography/Makefile
index d657089d7..9ac237d01 100644
--- a/lang/python-cryptography/Makefile
+++ b/lang/python-cryptography/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cryptography
PKG_VERSION:=1.5.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://pypi.python.org/packages/21/e1/37fc14f9d77924e84ba0dcb88eb8352db914583af229287c6c965d66ba0d
diff --git a/lang/python-cryptography/patches/001-disable-setup-requirements.patch b/lang/python-cryptography/patches/001-disable-setup-requirements.patch
new file mode 100644
index 000000000..07ae483c2
--- /dev/null
+++ b/lang/python-cryptography/patches/001-disable-setup-requirements.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index b5c05df..a777dd7 100644
+--- a/setup.py
++++ b/setup.py
+@@ -266,6 +266,7 @@ class DummyPyTest(test):
+ with open(os.path.join(base_dir, "README.rst")) as f:
+ long_description = f.read()
+
++setup_requirements=[]
+
+ setup(
+ name=about["__title__"],