aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-17 22:09:32 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-19 01:56:23 +0800
commit9636f6f4477c228e0b3c23f4082b53ab7c61f3ce (patch)
tree73d8cd162517afb5fe79e8c924876ed1b7a1f9b6 /lang
parent58719a3c4bd75479f992982bef3b77fef8310726 (diff)
python3: Use PYTHON3_PKG_BUILD to control default Python package build
This replaces the use of BUILD_VARIANT with PYTHON3_PKG_BUILD to opt in/out of the default Python package build recipe (Py3Build/Compile). PYTHON3_PKG_BUILD defaults to true (1), i.e. if a package includes python3-package.mk, then by default it will set the package's Build/Compile to Py3Build/Compile. If PYTHON3_PKG_BUILD is set to 0 before python3-package.mk is included, then Build/Compile will not be modified. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python3-package.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/python/python3-package.mk b/lang/python/python3-package.mk
index 878108c54..b16773263 100644
--- a/lang/python/python3-package.mk
+++ b/lang/python/python3-package.mk
@@ -207,8 +207,8 @@ endef
Py3Build/Compile=$(Py3Build/Compile/Default)
-ifeq ($(BUILD_VARIANT),python3)
-define Build/Compile
- $(call Py3Build/Compile)
-endef
-endif # python3
+PYTHON3_PKG_BUILD ?= 1
+
+ifeq ($(strip $(PYTHON3_PKG_BUILD)),1)
+ Build/Compile=$(Py3Build/Compile)
+endif