aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-15 21:58:40 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-19 01:56:23 +0800
commit58719a3c4bd75479f992982bef3b77fef8310726 (patch)
tree8b417bfb34660fdce33875fd7cf8ba62a7e4a9f9 /lang
parentba127c155a104be0a93c6f85877db0d6f27ba9df (diff)
python3: Remove MIPS16 changes from python3-package.mk
There are no bug reports or other evidence to suggest Python is not compatible with MIPS16 compilation. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python3-package.mk7
1 files changed, 0 insertions, 7 deletions
diff --git a/lang/python/python3-package.mk b/lang/python/python3-package.mk
index fe0df5a11..878108c54 100644
--- a/lang/python/python3-package.mk
+++ b/lang/python/python3-package.mk
@@ -27,13 +27,6 @@ CONFIGURE_ARGS += \
_python_prefix="/usr" \
_python_exec_prefix="/usr"
-PKG_USE_MIPS16:=0
-# This is required in addition to PKG_USE_MIPS16:=0 because otherwise MIPS16
-# flags are inherited from the Python base package (via sysconfig module)
-ifdef CONFIG_USE_MIPS16
- TARGET_CFLAGS += -mno-mips16 -mno-interlink-mips16
-endif
-
PYTHON3_VARS = \
CC="$(TARGET_CC)" \
CCSHARED="$(TARGET_CC) $(FPIC)" \