aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-01 16:50:58 -0700
committerGitHub <noreply@github.com>2019-11-01 16:50:58 -0700
commit5c204b857440440bb17a50a3a92ba31861274526 (patch)
treef042faffb13889c4b5e28e96f5c113f97c97b57e /lang
parent2f26928c5b87091314de2639d20081c9dfed16ee (diff)
parent455fe3dc034d9bedd82a5b959cdc5593d446dea3 (diff)
Merge pull request #10405 from ja-pa/python-pyparsing
python-pyparsing: add new package
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-pyparsing/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/lang/python/python-pyparsing/Makefile b/lang/python/python-pyparsing/Makefile
new file mode 100644
index 000000000..f4f3d114e
--- /dev/null
+++ b/lang/python/python-pyparsing/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pyparsing
+PKG_VERSION:=2.4.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=pyparsing
+PKG_HASH:=6f98a7b9397e206d78cc01df10131398f1c8b8510a2f4d97d9abd82e1aacdd80
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-pyparsing
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Library for constructing grammar directly in python
+ URL:=https://github.com/pyparsing/pyparsing/
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-pyparsing/description
+ The pyparsing module is an alternative approach to creating
+ and executing simple grammars, vs. the traditional lex/yacc
+ approach, or the use of regular expressions.
+ The pyparsing module provides a library of classes that
+ client code uses to construct the grammar directly in Python code.
+endef
+
+$(eval $(call Py3Package,python3-pyparsing))
+$(eval $(call BuildPackage,python3-pyparsing))
+$(eval $(call BuildPackage,python3-pyparsing-src))