aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-01 16:50:46 -0700
committerGitHub <noreply@github.com>2019-11-01 16:50:46 -0700
commit2f26928c5b87091314de2639d20081c9dfed16ee (patch)
treebe175c967088c75683e9ae589f273e3ea074ae98 /lang
parente89ddbeb98750f3b68e64e256a4c903ac24f09de (diff)
parent92398d28a53dcf87d5e30966c30119fd7c023ad4 (diff)
Merge pull request #10411 from ja-pa/python-atomicwrites
python-atomicwrites: add new package
Diffstat (limited to 'lang')
-rw-r--r--lang/python/python-atomicwrites/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/lang/python/python-atomicwrites/Makefile b/lang/python/python-atomicwrites/Makefile
new file mode 100644
index 000000000..315f2c33c
--- /dev/null
+++ b/lang/python/python-atomicwrites/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-atomicwrites
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=atomicwrites
+PKG_HASH:=75a9445bac02d8d058d5e1fe689654ba5a6556a1dfd8ce6ec55a0ed79866cfa6
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-atomicwrites
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Atomic file writes
+ URL:=https://github.com/untitaker/python-atomicwrites
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-atomicwrites/description
+ Python library for atomic file writes.
+endef
+
+$(eval $(call Py3Package,python3-atomicwrites))
+$(eval $(call BuildPackage,python3-atomicwrites))
+$(eval $(call BuildPackage,python3-atomicwrites-src))