aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/rust-package.mk
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-10-02 02:16:22 +0800
committerJeffery To <jeffery.to@gmail.com>2023-10-11 15:50:23 +0800
commit5c5123f0f63cfda1d4f17a5d315356883fd82923 (patch)
tree097c5475d8b17040edfa142d9a63ab205ee080f7 /lang/rust/rust-package.mk
parent49aaf19c65a35c37725ead7a438684411b512d6f (diff)
rust: Move cargo config options into environment variables
This also: * Modify the "release" profile in place of adding the "stripped" profile Only the profile for target is modified; there are no file size constraints for host. * For host, build with the "release" profile * For target, build with either the "dev" or "release" profile based on CONFIG_DEBUG There is no environment variable to specify the "strip" option, but enabling this option is not necessary as the build system will already strip binaries based on CONFIG_NO_STRIP / CONFIG_USE_STRIP / CONFIG_USE_SSTRIP. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/rust/rust-package.mk')
-rw-r--r--lang/rust/rust-package.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/rust/rust-package.mk b/lang/rust/rust-package.mk
index 231828bab..713d37d5b 100644
--- a/lang/rust/rust-package.mk
+++ b/lang/rust/rust-package.mk
@@ -21,13 +21,15 @@ define Build/Compile/Cargo
( \
cd $(PKG_BUILD_DIR) ; \
CARGO_HOME=$(CARGO_HOME) \
+ CARGO_PROFILE_RELEASE_OPT_LEVEL=s \
+ CARGO_TARGET_$(subst -,_,$(call toupper,$(RUSTC_TARGET_ARCH)))_LINKER=$(TARGET_CC_NOCACHE) \
TARGET_CFLAGS="$(TARGET_CFLAGS) $(RUSTC_CFLAGS)" \
TARGET_CC=$(TARGET_CC_NOCACHE) \
CC=$(HOSTCC_NOCACHE) \
RUSTFLAGS="$(CARGO_RUSTFLAGS)" \
$(CARGO_VARS) \
cargo install -v \
- --profile stripped \
+ --profile $(CARGO_PKG_PROFILE) \
--target $(RUSTC_TARGET_ARCH) \
$(if $(strip $(RUST_PKG_FEATURES)),--features "$(strip $(RUST_PKG_FEATURES))") \
--root $(PKG_INSTALL_DIR) \