aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/rust-package.mk
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-23 00:02:01 +0800
committerJeffery To <jeffery.to@gmail.com>2023-10-11 15:50:22 +0800
commit49aaf19c65a35c37725ead7a438684411b512d6f (patch)
treea7fa4db8ac92355a1e81e3557d370b4d9217365a /lang/rust/rust-package.mk
parent855623d8cce4db8655af58bed5d52c64d38608c5 (diff)
rust: Install to $(STAGING_DIR)/host
This allows rustc/cargo/etc to be called without having to set PATH, as $(STAGING_DIR)/host/bin is already in PATH. This also fixes CARGO_HOME not being set during Host/Configure and Host/Compile. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/rust/rust-package.mk')
-rw-r--r--lang/rust/rust-package.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/lang/rust/rust-package.mk b/lang/rust/rust-package.mk
index 8d30ee86c..231828bab 100644
--- a/lang/rust/rust-package.mk
+++ b/lang/rust/rust-package.mk
@@ -20,7 +20,6 @@ include $(RUST_INCLUDE_DIR)/rust-values.mk
define Build/Compile/Cargo
( \
cd $(PKG_BUILD_DIR) ; \
- export PATH="$(CARGO_HOME)/bin:$(PATH)" ; \
CARGO_HOME=$(CARGO_HOME) \
TARGET_CFLAGS="$(TARGET_CFLAGS) $(RUSTC_CFLAGS)" \
TARGET_CC=$(TARGET_CC_NOCACHE) \