aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/rust-package.mk
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-23 20:24:37 +0800
committerJeffery To <jeffery.to@gmail.com>2023-10-11 15:50:24 +0800
commit0dfc1b508d5e5b361978ef9783cb63775176c305 (patch)
tree87d123b9d63916b84de9d88e81502e38a6bf4a0b /lang/rust/rust-package.mk
parent9db7284d589dc8490f8c7dbe56af731fce953eda (diff)
rust: Use make's jobserver when building packages
This allows cargo to use make's jobserver when building packages, by marking the cargo command as recursive (with the + prefix[1]) and setting MAKEFLAGS. This also: * Give cargo/x.py the build directory instead of having to change the current directory (and opening subshells) * Set PKG_BUILD_PARALLEL/HOST_BUILD_PARALLEL for Rust packages to enable the use of make's jobserver [1]: https://www.gnu.org/software/make/manual/html_node/POSIX-Jobserver.html Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/rust/rust-package.mk')
-rw-r--r--lang/rust/rust-package.mk21
1 files changed, 10 insertions, 11 deletions
diff --git a/lang/rust/rust-package.mk b/lang/rust/rust-package.mk
index 6deb859fb..24341d706 100644
--- a/lang/rust/rust-package.mk
+++ b/lang/rust/rust-package.mk
@@ -17,21 +17,20 @@ include $(RUST_INCLUDE_DIR)/rust-values.mk
CARGO_PKG_VARS= \
$(CARGO_PKG_CONFIG_VARS) \
- CC=$(HOSTCC_NOCACHE)
+ CC=$(HOSTCC_NOCACHE) \
+ MAKEFLAGS="$(PKG_JOBS)"
# $(1) path to the package (optional)
# $(2) additional arguments to cargo (optional)
define Build/Compile/Cargo
- ( \
- cd $(PKG_BUILD_DIR) ; \
- $(CARGO_PKG_VARS) \
- cargo install -v \
- --profile $(CARGO_PKG_PROFILE) \
- $(if $(strip $(RUST_PKG_FEATURES)),--features "$(strip $(RUST_PKG_FEATURES))") \
- --root $(PKG_INSTALL_DIR) \
- --path "$(if $(strip $(1)),$(strip $(1)),.)" \
- $(2) ; \
- )
+ +$(CARGO_PKG_VARS) \
+ cargo install -v \
+ --profile $(CARGO_PKG_PROFILE) \
+ $(if $(strip $(RUST_PKG_FEATURES)),--features "$(strip $(RUST_PKG_FEATURES))") \
+ --root $(PKG_INSTALL_DIR) \
+ --path "$(PKG_BUILD_DIR)/$(if $(strip $(1)),$(strip $(1)))" \
+ $(if $(filter --jobserver%,$(PKG_JOBS)),,-j1) \
+ $(2)
endef
define RustBinPackage