aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/rust-package.mk
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-25 11:58:12 +0800
committerJeffery To <jeffery.to@gmail.com>2023-10-11 15:50:23 +0800
commit9db7284d589dc8490f8c7dbe56af731fce953eda (patch)
treebd7329983710c19d0428ce89b358c7b41b59f87f /lang/rust/rust-package.mk
parent853c9c9e8625c54a2c3214b2ef770ffc76bd3495 (diff)
rust: Consolidate cargo environment variables
This consolidates all environment variables for cargo into: * CARGO_HOST_CONFIG_VARS / CARGO_PKG_CONFIG_VARS These contain all cargo-specific environment variables, i.e. without "common" variables like CC. * CARGO_HOST_VARS / CARGO_PKG_VARS (renamed from CARGO_VARS) These contain all environment variables to be passed to cargo. This also: * Set the CARGO_BUILD_TARGET environment variable instead of using the --target command-line option * Update Python include files to use CARGO_HOST_CONFIG_VARS / CARGO_PKG_CONFIG_VARS Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/rust/rust-package.mk')
-rw-r--r--lang/rust/rust-package.mk14
1 files changed, 5 insertions, 9 deletions
diff --git a/lang/rust/rust-package.mk b/lang/rust/rust-package.mk
index 713d37d5b..6deb859fb 100644
--- a/lang/rust/rust-package.mk
+++ b/lang/rust/rust-package.mk
@@ -15,22 +15,18 @@ ifeq ($(origin RUST_INCLUDE_DIR),undefined)
endif
include $(RUST_INCLUDE_DIR)/rust-values.mk
+CARGO_PKG_VARS= \
+ $(CARGO_PKG_CONFIG_VARS) \
+ CC=$(HOSTCC_NOCACHE)
+
# $(1) path to the package (optional)
# $(2) additional arguments to cargo (optional)
define Build/Compile/Cargo
( \
cd $(PKG_BUILD_DIR) ; \
- CARGO_HOME=$(CARGO_HOME) \
- CARGO_PROFILE_RELEASE_OPT_LEVEL=s \
- CARGO_TARGET_$(subst -,_,$(call toupper,$(RUSTC_TARGET_ARCH)))_LINKER=$(TARGET_CC_NOCACHE) \
- TARGET_CFLAGS="$(TARGET_CFLAGS) $(RUSTC_CFLAGS)" \
- TARGET_CC=$(TARGET_CC_NOCACHE) \
- CC=$(HOSTCC_NOCACHE) \
- RUSTFLAGS="$(CARGO_RUSTFLAGS)" \
- $(CARGO_VARS) \
+ $(CARGO_PKG_VARS) \
cargo install -v \
--profile $(CARGO_PKG_PROFILE) \
- --target $(RUSTC_TARGET_ARCH) \
$(if $(strip $(RUST_PKG_FEATURES)),--features "$(strip $(RUST_PKG_FEATURES))") \
--root $(PKG_INSTALL_DIR) \
--path "$(if $(strip $(1)),$(strip $(1)),.)" \