aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <aa@ocedo.com>2014-10-20 19:07:23 +0300
committerAlexandru Ardelean <aa@ocedo.com>2014-10-20 19:07:28 +0300
commitf699a1f8f992f01401fa0399a42f5b776541220c (patch)
tree483d77d825bfdf26b243db1eb09384d2d5fbc597 /lang/python
parent774bb4449407f8033e631b367281faeb123000f4 (diff)
python: fix source folder for libpython
This fix is quite critical since it fixes copying the libpython shared lib. The previous source folder we've used is ok, it has the shared lib, but libpython2.7.so is not a symlink of libpython2.7.so.1.0, but rather a copy of it. Which means that libpython2.7.so takes twice as much space on the target's flash. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index edecefe1d..0d4dc7bfa 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -176,7 +176,7 @@ define Build/InstallDev
$(1)/usr/include/
$(CP) \
$(STAGING_DIR_HOST)/lib/python$(PYTHON_VERSION) \
- $(PKG_BUILD_DIR)/libpython$(PYTHON_VERSION).so* \
+ $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* \
$(1)/usr/lib/
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/config \
@@ -389,7 +389,7 @@ endef
define PyPackage/python/install
$(LN) python$(PYTHON_VERSION) $(1)/usr/bin/python
$(LN) python$(PYTHON_VERSION) $(1)/usr/bin/python2
- $(CP) $(PKG_BUILD_DIR)/libpython$(PYTHON_VERSION).so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* $(1)/usr/lib/
endef
define PyPackage/python-doc/filespec