aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-05-20 04:30:45 +0800
committerJeffery To <jeffery.to@gmail.com>2020-05-20 04:30:45 +0800
commitd2b0cc523dadc6a8ec4535561860b77cc9ee4fe2 (patch)
tree08e3b66b2b47b0a7f11df7f72baf030c19b0164a /lang/python
parent5e84c4872c19d61841e8ee0ce6fc5e25e3e81d68 (diff)
python3-openssl: Add dependency on ca-certs
The ssl module assumes OpenSSL can load the default trust anchors (root CA certificates). From https://github.com/openwrt/packages/issues/12209 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python3/Makefile2
-rw-r--r--lang/python/python3/files/python3-package-openssl.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/python/python3/Makefile b/lang/python/python3/Makefile
index debb435ee..a0c46ffcc 100644
--- a/lang/python/python3/Makefile
+++ b/lang/python/python3/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
include ../python3-version.mk
PKG_NAME:=python3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
diff --git a/lang/python/python3/files/python3-package-openssl.mk b/lang/python/python3/files/python3-package-openssl.mk
index 6971993f7..4d13afd20 100644
--- a/lang/python/python3/files/python3-package-openssl.mk
+++ b/lang/python/python3/files/python3-package-openssl.mk
@@ -8,7 +8,7 @@
define Package/python3-openssl
$(call Package/python3/Default)
TITLE:=Python $(PYTHON3_VERSION) SSL module
- DEPENDS:=+python3-light +libopenssl
+ DEPENDS:=+python3-light +libopenssl +ca-certs
endef
$(eval $(call Py3BasePackage,python3-openssl, \