aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <aa@ocedo.com>2014-12-15 10:19:12 +0200
committerAlexandru Ardelean <aa@ocedo.com>2015-01-06 14:15:02 +0200
commit8b86c1528afe73e858596b248fef4bc5a64da321 (patch)
tree82376ddeb1cfc6fdfaec88d97dc64561d912800b /lang/python
parent9b94e3cb6eab07e6ba44ca74ea5ffc19f39d0bd7 (diff)
python: add default PyPackage/filespec if not defined
Most packages will install in /usr/lib/python$(PYTHON_VERSION)/site-packages Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/files/python-package.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/python/files/python-package.mk b/lang/python/files/python-package.mk
index 71d500d1d..d9e8df9c4 100644
--- a/lang/python/files/python-package.mk
+++ b/lang/python/files/python-package.mk
@@ -38,6 +38,14 @@ ifdef CONFIG_USE_MIPS16
endif
define PyPackage
+
+ # Add default PyPackage filespec none defined
+ ifndef PyPackage/$(1)/filespec
+ define PyPackage/$(1)/filespec
+ +|$(PYTHON_PKG_DIR)
+ endef
+ endif
+
$(call shexport,PyPackage/$(1)/filespec)
define Package/$(1)/install
@@ -98,3 +106,4 @@ define Build/Compile/PyMod
)
find $(PKG_INSTALL_DIR) -name "*\.pyc" -o -name "*\.pyo" | xargs rm -f
endef
+