aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/python/files/python-package.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/python/files/python-package.mk b/lang/python/files/python-package.mk
index 71d500d1d..d9e8df9c4 100644
--- a/lang/python/files/python-package.mk
+++ b/lang/python/files/python-package.mk
@@ -38,6 +38,14 @@ ifdef CONFIG_USE_MIPS16
endif
define PyPackage
+
+ # Add default PyPackage filespec none defined
+ ifndef PyPackage/$(1)/filespec
+ define PyPackage/$(1)/filespec
+ +|$(PYTHON_PKG_DIR)
+ endef
+ endif
+
$(call shexport,PyPackage/$(1)/filespec)
define Package/$(1)/install
@@ -98,3 +106,4 @@ define Build/Compile/PyMod
)
find $(PKG_INSTALL_DIR) -name "*\.pyc" -o -name "*\.pyo" | xargs rm -f
endef
+