aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorAlexandru Ardelean <alex@shruggie.ro>2023-09-10 16:14:59 +0300
committerGitHub <noreply@github.com>2023-09-10 16:14:59 +0300
commit681651db4fbc8dd5cf6b1710c789ff9f046d5974 (patch)
tree5d3afea7081e4869569b75f70d92446cc2c1759d /lang/python
parentd94a5cf5857415c145a076ea681c7fce45a3a0f8 (diff)
parent4872c325808357c0cb81a4367d053cc5b5468028 (diff)
Merge pull request #22039 from jefferyto/xmltodict-0.13.0
xmltodict: Update to 0.13.0, rename source package
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python-xmltodict/Makefile (renamed from lang/python/xmltodict/Makefile)14
1 files changed, 6 insertions, 8 deletions
diff --git a/lang/python/xmltodict/Makefile b/lang/python/python-xmltodict/Makefile
index 44cf4cd50..87b841f51 100644
--- a/lang/python/xmltodict/Makefile
+++ b/lang/python/python-xmltodict/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-xmltodict
-PKG_VERSION:=0.12.0
-PKG_RELEASE:=2
+PKG_VERSION:=0.13.0
+PKG_RELEASE:=1
PYPI_NAME:=xmltodict
-PKG_HASH:=50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d166d8a21
+PKG_HASH:=341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=MIT
@@ -28,14 +28,12 @@ define Package/python3-xmltodict
SUBMENU:=Python
TITLE:=Work with XML like JSON
URL:=https://github.com/martinblech/xmltodict
- DEPENDS:= \
- +python3-light \
- +python3-xml \
- +python3-urllib
+ DEPENDS:=+python3-light +python3-xml
endef
define Package/python3-xmltodict/description
- xmltodict is a Python module that makes working with XML feel like you are working with JSON.
+xmltodict is a Python module that makes working with XML feel like you
+are working with JSON.
endef
$(eval $(call Py3Package,python3-xmltodict))