aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-09-05 05:56:22 +0800
committerJeffery To <jeffery.to@gmail.com>2023-09-05 05:57:23 +0800
commit4872c325808357c0cb81a4367d053cc5b5468028 (patch)
tree00f355d85ce21b8d14ae19efa147503808dca980 /lang/python
parent1e1b2051db47a82513f4eb4e9da892207785b7e2 (diff)
xmltodict: Update to 0.13.0, rename source package
This renames the source package to python-xmltodict to match other Python packages. This also updates the list of dependencies. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/python-xmltodict/Makefile (renamed from lang/python/xmltodict/Makefile)14
1 files changed, 6 insertions, 8 deletions
diff --git a/lang/python/xmltodict/Makefile b/lang/python/python-xmltodict/Makefile
index 44cf4cd50..87b841f51 100644
--- a/lang/python/xmltodict/Makefile
+++ b/lang/python/python-xmltodict/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-xmltodict
-PKG_VERSION:=0.12.0
-PKG_RELEASE:=2
+PKG_VERSION:=0.13.0
+PKG_RELEASE:=1
PYPI_NAME:=xmltodict
-PKG_HASH:=50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d166d8a21
+PKG_HASH:=341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=MIT
@@ -28,14 +28,12 @@ define Package/python3-xmltodict
SUBMENU:=Python
TITLE:=Work with XML like JSON
URL:=https://github.com/martinblech/xmltodict
- DEPENDS:= \
- +python3-light \
- +python3-xml \
- +python3-urllib
+ DEPENDS:=+python3-light +python3-xml
endef
define Package/python3-xmltodict/description
- xmltodict is a Python module that makes working with XML feel like you are working with JSON.
+xmltodict is a Python module that makes working with XML feel like you
+are working with JSON.
endef
$(eval $(call Py3Package,python3-xmltodict))