aboutsummaryrefslogtreecommitdiff
path: root/lang/perl
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-10-16 16:24:55 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2017-10-16 16:40:22 -0600
commitd58ac19c9f4f8422eb4793770e6d2637d222c6a4 (patch)
tree5191cdd3b37bd95db31527fe15808b466c87663f /lang/perl
parentb392cd595af6b15f2e703f305c6351d833312bf1 (diff)
perl: put -rdynamic in proper build variable
The standard way to pass -rdynamic (or -Wl,--dynamic-export) is via the $ccdlflags variable. Do what is best practice. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'lang/perl')
-rw-r--r--lang/perl/Makefile4
-rw-r--r--lang/perl/files/base.config2
2 files changed, 3 insertions, 3 deletions
diff --git a/lang/perl/Makefile b/lang/perl/Makefile
index 6f07b49fa..015b05489 100644
--- a/lang/perl/Makefile
+++ b/lang/perl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=perl
PKG_VERSION:=5.24.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=\
https://cpan.metacpan.org/src/5.0 \
@@ -96,7 +96,7 @@ define Build/Configure
-Dowrt:gccversion=$(CONFIG_GCC_VERSION) \
-Dowrt:target_cross='$(TARGET_CROSS)' \
-Dowrt:cflags='$(TARGET_CFLAGS_PERL) $(TARGET_CPPFLAGS_PERL)' \
- -Dowrt:ldflags='-rdynamic $(TARGET_LDFLAGS)' \
+ -Dowrt:ldflags='$(TARGET_LDFLAGS)' \
-Dowrt:libc=$(subst uClibc,uclibc,$(CONFIG_LIBC)) \
-Dowrt:ipv6=$(if $($(CONFIG_IPV6)),define,undef) \
-Dowrt:threads=$(if $(CONFIG_PERL_THREADS),yes,no) \
diff --git a/lang/perl/files/base.config b/lang/perl/files/base.config
index ce1ae5ab6..1b17e1c18 100644
--- a/lang/perl/files/base.config
+++ b/lang/perl/files/base.config
@@ -1006,7 +1006,7 @@ full_ar="${owrt:target_cross}ar"
cppflags="$owrt:cflags"
ccflags="-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 $owrt:cflags"
ccflags_uselargefiles='-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
-ccdlflags="-fPIC -Wl,-rpath,$owrt:perllibpath/CORE"
+ccdlflags="-fPIC -rdynamic -Wl,-rpath,$owrt:perllibpath/CORE"
cccdlflags='-fPIC'
ldflags="$owrt:ldflags"
ldflags_uselargefiles=''