aboutsummaryrefslogtreecommitdiff
path: root/lang/node-serialport/Makefile
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2020-09-18 15:59:42 +0900
committerHirokazu MORIKAWA <morikw2@gmail.com>2020-09-18 15:59:42 +0900
commitbda9bdd122cbf1c09d0142cb6e0f5b6dd98bc2cf (patch)
tree7d9b41bff5529c2019fa64fee3cb38e0f4745110 /lang/node-serialport/Makefile
parent64cf9fb779b052efb97b901d76ea818989638283 (diff)
node-serialport: update to 9.0.1
Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
Diffstat (limited to 'lang/node-serialport/Makefile')
-rw-r--r--lang/node-serialport/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/node-serialport/Makefile b/lang/node-serialport/Makefile
index 1d629731c..ea1acc7f3 100644
--- a/lang/node-serialport/Makefile
+++ b/lang/node-serialport/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=serialport
PKG_NAME:=node-$(PKG_NPM_NAME)
-PKG_VERSION:=8.0.7
+PKG_VERSION:=9.0.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NPM_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://registry.npmjs.org/$(PKG_NPM_NAME)/-/
-PKG_HASH:=b70000ad4560dbd7170e657554d6302024a340ae868e1db0fc672aaab2efbd9c
+PKG_HASH:=9f837bc5b64dde03aaf097093a2674789405f436fd367903502d3e2e17fcd4a3
PKG_BUILD_DEPENDS:=node/host
PKG_USE_MIPS16:=0
@@ -65,7 +65,7 @@ define Package/node-serialport/install
$(INSTALL_DIR) $(1)/usr/lib/node/$(PKG_NPM_NAME)
$(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/$(PKG_NPM_NAME)/{package.json,LICENSE,*.md} \
$(1)/usr/lib/node/$(PKG_NPM_NAME)/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/$(PKG_NPM_NAME)/test.js \
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/$(PKG_NPM_NAME)/*.js \
$(1)/usr/lib/node/$(PKG_NPM_NAME)/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/$(PKG_NPM_NAME)/{node_modules,lib} \
$(1)/usr/lib/node/$(PKG_NPM_NAME)/