aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/node-serialport/Makefile6
-rw-r--r--lang/node-serialport/patches/001-turn_off_depends.patch10
2 files changed, 8 insertions, 8 deletions
diff --git a/lang/node-serialport/Makefile b/lang/node-serialport/Makefile
index 1d629731c..ea1acc7f3 100644
--- a/lang/node-serialport/Makefile
+++ b/lang/node-serialport/Makefile
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=serialport
PKG_NAME:=node-$(PKG_NPM_NAME)
-PKG_VERSION:=8.0.7
+PKG_VERSION:=9.0.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NPM_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://registry.npmjs.org/$(PKG_NPM_NAME)/-/
-PKG_HASH:=b70000ad4560dbd7170e657554d6302024a340ae868e1db0fc672aaab2efbd9c
+PKG_HASH:=9f837bc5b64dde03aaf097093a2674789405f436fd367903502d3e2e17fcd4a3
PKG_BUILD_DEPENDS:=node/host
PKG_USE_MIPS16:=0
@@ -65,7 +65,7 @@ define Package/node-serialport/install
$(INSTALL_DIR) $(1)/usr/lib/node/$(PKG_NPM_NAME)
$(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/$(PKG_NPM_NAME)/{package.json,LICENSE,*.md} \
$(1)/usr/lib/node/$(PKG_NPM_NAME)/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/$(PKG_NPM_NAME)/test.js \
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/$(PKG_NPM_NAME)/*.js \
$(1)/usr/lib/node/$(PKG_NPM_NAME)/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/node_modules/$(PKG_NPM_NAME)/{node_modules,lib} \
$(1)/usr/lib/node/$(PKG_NPM_NAME)/
diff --git a/lang/node-serialport/patches/001-turn_off_depends.patch b/lang/node-serialport/patches/001-turn_off_depends.patch
index 9c4ebf841..1fa6701f0 100644
--- a/lang/node-serialport/patches/001-turn_off_depends.patch
+++ b/lang/node-serialport/patches/001-turn_off_depends.patch
@@ -3,8 +3,8 @@
@@ -46,7 +46,6 @@
],
"dependencies": {
- "@serialport/binding-mock": "^8.0.6",
-- "@serialport/bindings": "^8.0.7",
- "@serialport/parser-byte-length": "^8.0.6",
- "@serialport/parser-cctalk": "^8.0.6",
- "@serialport/parser-delimiter": "^8.0.6",
+ "@serialport/binding-mock": "^9.0.1",
+- "@serialport/bindings": "^9.0.1",
+ "@serialport/parser-byte-length": "^9.0.1",
+ "@serialport/parser-cctalk": "^9.0.1",
+ "@serialport/parser-delimiter": "^9.0.1",