aboutsummaryrefslogtreecommitdiff
path: root/lang/lua-lzlib/patches
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-04-30 04:10:29 +0200
committerNicolas Thill <nico@openwrt.org>2015-04-30 04:10:29 +0200
commit201aa65a56e9ecc7875f25997da4048fbedb0125 (patch)
treed518fa265de89615360fc6590892fe33471afa1f /lang/lua-lzlib/patches
parent1c0c31b69f2425faed76dfdb24e5f3f8acffa710 (diff)
lua-lzlib: fix build failure, honor cflags, cleanup
* fix failure on buildbot where lua devel files are searched in home directory * add a patch to pass proper target optimization flags * remove unused PKG_INSTALL & Build/Install Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'lang/lua-lzlib/patches')
-rw-r--r--lang/lua-lzlib/patches/001-allow_optim_flags.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/lang/lua-lzlib/patches/001-allow_optim_flags.patch b/lang/lua-lzlib/patches/001-allow_optim_flags.patch
new file mode 100644
index 000000000..78f981d23
--- /dev/null
+++ b/lang/lua-lzlib/patches/001-allow_optim_flags.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -14,7 +14,8 @@ LUABIN= $(LUA)/bin
+ ZLIB=../zlib-1.2.3
+
+ # no need to change anything below here
+-CFLAGS= $(INCS) $(DEFS) $(WARN) -O0 -fPIC
++CFLAGS= $(INCS) $(DEFS) $(WARN) $(OFLAGS) -fPIC
++OFLAGS= -O0
+ WARN= -g -Werror -Wall -pedantic #-ansi
+ INCS= -I$(LUAINC) -I$(ZLIB)
+ LIBS= -L$(ZLIB) -lz -L$(LUALIB) -L$(LUABIN) #-llua51