aboutsummaryrefslogtreecommitdiff
path: root/lang/lua-lzlib
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-04-30 04:10:29 +0200
committerNicolas Thill <nico@openwrt.org>2015-04-30 04:10:29 +0200
commit201aa65a56e9ecc7875f25997da4048fbedb0125 (patch)
treed518fa265de89615360fc6590892fe33471afa1f /lang/lua-lzlib
parent1c0c31b69f2425faed76dfdb24e5f3f8acffa710 (diff)
lua-lzlib: fix build failure, honor cflags, cleanup
* fix failure on buildbot where lua devel files are searched in home directory * add a patch to pass proper target optimization flags * remove unused PKG_INSTALL & Build/Install Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'lang/lua-lzlib')
-rw-r--r--lang/lua-lzlib/Makefile9
-rw-r--r--lang/lua-lzlib/patches/001-allow_optim_flags.patch12
2 files changed, 16 insertions, 5 deletions
diff --git a/lang/lua-lzlib/Makefile b/lang/lua-lzlib/Makefile
index 4b9468789..096cec0d7 100644
--- a/lang/lua-lzlib/Makefile
+++ b/lang/lua-lzlib/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lua-lzlib
PKG_VERSION:=0.4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
PKG_LICENSE:=MIT
@@ -19,8 +19,6 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=9fa3993bb4504fbbc10511cde141e1c6a48c072d
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL:=1
-
include $(INCLUDE_DIR)/package.mk
define Package/lua-lzlib
@@ -36,8 +34,9 @@ define Package/lua-lzlib/description
A library to access zlib library functions and also to read/write gzip files using an interface similar to the base io package.
endef
-define Build/Install
-endef
+MAKE_FLAGS += \
+ LUA="$(STAGING_DIR)/usr" \
+ OFLAGS="$(TARGET_CFLAGS)" \
define Package/lua-lzlib/install
$(INSTALL_DIR) $(1)/usr/lib/lua
diff --git a/lang/lua-lzlib/patches/001-allow_optim_flags.patch b/lang/lua-lzlib/patches/001-allow_optim_flags.patch
new file mode 100644
index 000000000..78f981d23
--- /dev/null
+++ b/lang/lua-lzlib/patches/001-allow_optim_flags.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -14,7 +14,8 @@ LUABIN= $(LUA)/bin
+ ZLIB=../zlib-1.2.3
+
+ # no need to change anything below here
+-CFLAGS= $(INCS) $(DEFS) $(WARN) -O0 -fPIC
++CFLAGS= $(INCS) $(DEFS) $(WARN) $(OFLAGS) -fPIC
++OFLAGS= -O0
+ WARN= -g -Werror -Wall -pedantic #-ansi
+ INCS= -I$(LUAINC) -I$(ZLIB)
+ LIBS= -L$(ZLIB) -lz -L$(LUALIB) -L$(LUABIN) #-llua51