aboutsummaryrefslogtreecommitdiff
path: root/lang/lua-cjson
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-13 01:00:20 +0800
committerJeffery To <jeffery.to@gmail.com>2019-10-13 02:01:34 +0800
commit53e1692ae91b1b5fc59a7e8ab7fb98f8775eb4b6 (patch)
tree49a758e5d65104f3f86247868009c5774d39e04b /lang/lua-cjson
parent7de37d7fea41a285c57a9593612548cd8b509ec0 (diff)
treewide: Use default PKG_BUILD_DIR when possible
This removes lines that set PKG_BUILD_DIR when the set value is no different from the default value. Specifically, the line is removed if the assigned value is: * $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION) The default PKG_BUILD_DIR was updated[1] to incorporate BUILD_VARIANT if it is set, so now this is identical to the default value. * $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR) if PKG_SOURCE_SUBDIR is set to $(PKG_NAME)-$(PKG_VERSION), making it the same as the previous case * $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) This is the same as the default PKG_BUILD_DIR when there is no BUILD_VARIANT. * $(BUILD_DIR)/[name]-$(PKG_VERSION) where [name] is a string that is identical to PKG_NAME [1]: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=e545fac8d968864a965edb9e50c6f90940b0a6c9 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/lua-cjson')
-rw-r--r--lang/lua-cjson/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/lang/lua-cjson/Makefile b/lang/lua-cjson/Makefile
index aea91a535..de727346a 100644
--- a/lang/lua-cjson/Makefile
+++ b/lang/lua-cjson/Makefile
@@ -18,7 +18,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.kyne.com.au/~mark/software/download/
PKG_HASH:=51bc69cd55931e0cba2ceae39e9efa2483f4292da3a88a1ed470eda829f6c778
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
HOST_BUILD_DEPENDS:=lua/host
include $(INCLUDE_DIR)/host-build.mk