aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-13 01:00:20 +0800
committerJeffery To <jeffery.to@gmail.com>2019-10-13 02:01:34 +0800
commit53e1692ae91b1b5fc59a7e8ab7fb98f8775eb4b6 (patch)
tree49a758e5d65104f3f86247868009c5774d39e04b /lang
parent7de37d7fea41a285c57a9593612548cd8b509ec0 (diff)
treewide: Use default PKG_BUILD_DIR when possible
This removes lines that set PKG_BUILD_DIR when the set value is no different from the default value. Specifically, the line is removed if the assigned value is: * $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION) The default PKG_BUILD_DIR was updated[1] to incorporate BUILD_VARIANT if it is set, so now this is identical to the default value. * $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR) if PKG_SOURCE_SUBDIR is set to $(PKG_NAME)-$(PKG_VERSION), making it the same as the previous case * $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) This is the same as the default PKG_BUILD_DIR when there is no BUILD_VARIANT. * $(BUILD_DIR)/[name]-$(PKG_VERSION) where [name] is a string that is identical to PKG_NAME [1]: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=e545fac8d968864a965edb9e50c6f90940b0a6c9 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/lpeg/Makefile2
-rw-r--r--lang/lua-cjson/Makefile1
-rw-r--r--lang/lua-libmodbus/Makefile2
-rw-r--r--lang/luasql/Makefile1
4 files changed, 0 insertions, 6 deletions
diff --git a/lang/lpeg/Makefile b/lang/lpeg/Makefile
index 03f8c7656..5d56fb261 100644
--- a/lang/lpeg/Makefile
+++ b/lang/lpeg/Makefile
@@ -17,8 +17,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.inf.puc-rio.br/~roberto/lpeg/
PKG_HASH:=6aad270b91d1b1c6fd75f68e162329a04a644e50e917d55f46cc8384b7120004
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
include $(INCLUDE_DIR)/package.mk
define Package/lpeg
diff --git a/lang/lua-cjson/Makefile b/lang/lua-cjson/Makefile
index aea91a535..de727346a 100644
--- a/lang/lua-cjson/Makefile
+++ b/lang/lua-cjson/Makefile
@@ -18,7 +18,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.kyne.com.au/~mark/software/download/
PKG_HASH:=51bc69cd55931e0cba2ceae39e9efa2483f4292da3a88a1ed470eda829f6c778
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
HOST_BUILD_DEPENDS:=lua/host
include $(INCLUDE_DIR)/host-build.mk
diff --git a/lang/lua-libmodbus/Makefile b/lang/lua-libmodbus/Makefile
index 8fd42b40a..12e599a7c 100644
--- a/lang/lua-libmodbus/Makefile
+++ b/lang/lua-libmodbus/Makefile
@@ -13,8 +13,6 @@ PKG_SOURCE_VERSION:=v$(PKG_VERSION)
PKG_MAINTAINER:=Karl Palsson <karlp@etactica.com>
PKG_LICENSE:=MIT
-PKG_BUILD_DIR:=$(BUILD_DIR)/lua-libmodbus-$(PKG_VERSION)
-
include $(INCLUDE_DIR)/package.mk
define Package/lua-libmodbus
diff --git a/lang/luasql/Makefile b/lang/luasql/Makefile
index 5355a824a..baea0c166 100644
--- a/lang/luasql/Makefile
+++ b/lang/luasql/Makefile
@@ -14,7 +14,6 @@ PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/keplerproject/luasql/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=db2458a8c8c5f3bc717e4030fe2878f1ad8d71e437ec6149c381eebad5d525c5
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_MAINTAINER:=
PKG_LICENSE:=MIT