aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorSergey V. Lobanov <sergey@lobanov.in>2022-01-18 16:36:20 +0300
committerRosen Penev <rosenp@gmail.com>2022-01-18 18:03:44 -0800
commit75c25bef6da73c65823ac6d3ccbc7342bf794fb7 (patch)
tree2e4d251b7fad621d07a3ac85d1c2f8a84271a369 /devel
parenta2427edf76fffd294fbcc70f94c7d59d420d07b4 (diff)
lpc21isp: fix build on macos
lpc21isp Makefile detects Darwin and defines __APPLE__ that is not required for cross-compile build for OpenWrt This patch sets OSTYPE="Linux" due to OpenWrt is always Linux Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
Diffstat (limited to 'devel')
-rw-r--r--devel/lpc21isp/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/lpc21isp/Makefile b/devel/lpc21isp/Makefile
index a12f8b219..cdf6cb72f 100644
--- a/devel/lpc21isp/Makefile
+++ b/devel/lpc21isp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lpc21isp
PKG_VERSION:=197
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_LICENSE:=LGPL-3.0-or-later
PKG_LICENSE_FILES:=README gpl.txt lgpl-3.0.txt
@@ -36,6 +36,9 @@ endef
TARGET_CFLAGS += $(if $(CONFIG_USE_GLIBC),-lc -lgcc_eh)
+MAKE_FLAGS += \
+ OSTYPE="Linux"
+
define Package/lpc21isp/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lpc21isp $(1)/usr/sbin/