aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorJohn Audia <therealgraysky@proton.me>2024-03-21 05:48:18 -0400
committerJohn Audia <therealgraysky@proton.me>2024-03-31 09:35:51 -0400
commit4948049d92af8f38a8dddcb4ead3afe9b0fcbea9 (patch)
tree7a57ccc41a4e1f9d2744fd0d8f90490669be1e97 /admin
parent8bbc9c7d796fc4685c9839839bed3b057aa18397 (diff)
htop: build with CONFIG_HTOP_LMSENSORS=y
Default CONFIG_HTOP_LMSENSORS to y so users just need to install libsensors, no need to build your own, but no need to pay the size price when you don't use it. Closes #23700. Signed-off-by: John Audia <therealgraysky@proton.me>
Diffstat (limited to 'admin')
-rw-r--r--admin/htop/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/admin/htop/Makefile b/admin/htop/Makefile
index 155363106..f54ce4d1b 100644
--- a/admin/htop/Makefile
+++ b/admin/htop/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=htop
PKG_VERSION:=3.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/htop-dev/htop/tar.gz/$(PKG_VERSION)?
@@ -48,11 +48,12 @@ define Package/htop/config
config HTOP_LMSENSORS
bool "Compile Htop with lm-sensors support"
depends on PACKAGE_htop
- default y if TARGET_x86
+ default y
help
Build htop with lm-sensors support.
- This doesn't add lm-sensors as dependency,
- if present it'll loaded using dlopen().
+ This increases the binary by approx 5 kB.
+ Users wanting this functionality need to
+ install libsensors.
endef
CONFIGURE_ARGS += \