aboutsummaryrefslogtreecommitdiff
path: root/admin
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2024-03-06 01:18:34 -0800
committerTony Ambardar <itugrok@yahoo.com>2024-03-06 05:44:46 -0800
commit3cf17ad13023928f5eab925e1d157319a74f50ef (patch)
treedcedb0107605ee3b5d87678e7a1fc6b82b6384fb /admin
parent3f592f6d5940065019b9656cae6c4bd12ecb444b (diff)
zabbix: zabbix_helper_mac80211.c: use POSIX <libgen.h> header
The musl libc only implements POSIX basename() but provided a GNU header kludge in <string.h>, which was removed in musl 1.2.5 [1]. Use the standard <libgen.h> header to avoid compilation warnings like: zabbix-6.4.7/zabbix-extra-mac80211/zabbix_helper_mac80211.c:37:11: warning: implicit declaration of function 'basename' [-Wimplicit-function-declaration] 37 | phy = basename(phy); | ^~~~~~~~ zabbix-6.4.7/zabbix-extra-mac80211/zabbix_helper_mac80211.c:37:9: warning: assignment to 'char *' from 'int' makes pointer from integer without a cast [-Wint-conversion] 37 | phy = basename(phy); | ^ zabbix-6.4.7/zabbix-extra-mac80211/zabbix_helper_mac80211.c:38:10: warning: assignment to 'char *' from 'int' makes pointer from integer without a cast [-Wint-conversion] 38 | stat = basename(stat); | ^ Link 1: https://git.musl-libc.org/cgit/musl/log/?qt=grep&q=basename Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'admin')
-rw-r--r--admin/zabbix/Makefile2
-rw-r--r--admin/zabbix/files/zabbix_helper_mac80211.c1
2 files changed, 2 insertions, 1 deletions
diff --git a/admin/zabbix/Makefile b/admin/zabbix/Makefile
index c4f8c464a..b395b6134 100644
--- a/admin/zabbix/Makefile
+++ b/admin/zabbix/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zabbix
PKG_VERSION:=6.4.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://cdn.zabbix.com/zabbix/sources/stable/$(basename $(PKG_VERSION))/ \
diff --git a/admin/zabbix/files/zabbix_helper_mac80211.c b/admin/zabbix/files/zabbix_helper_mac80211.c
index 1442d2743..e03c46c3d 100644
--- a/admin/zabbix/files/zabbix_helper_mac80211.c
+++ b/admin/zabbix/files/zabbix_helper_mac80211.c
@@ -1,6 +1,7 @@
#define _GNU_SOURCE
#include <stdio.h>
#include <string.h>
+#include <libgen.h>
#include <stdlib.h>
#include <sys/types.h>
#include <dirent.h>