aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2016-08-19 18:40:41 -0400
committerTed Hess <thess@kitschensync.net>2016-08-19 18:50:29 -0400
commitec133992b73d9fdc11c3c5444fc8e4b06138ae72 (patch)
tree1d1f7ee326a63cf592a2b18e65195b4dfecbc737
parentd875334e5e30412777814494b4a323f8a35e752e (diff)
ffmpeg: Dependency cleanup
Custom builds need to select x264 and/or lame-lib explictly. Automatic CONFIG_ALL builds of ffmpeg-full include x264 and lame. Signed-off-by: Ted Hess <thess@kitschensync.net>
-rw-r--r--multimedia/ffmpeg/Config.in4
-rw-r--r--multimedia/ffmpeg/Makefile15
2 files changed, 11 insertions, 8 deletions
diff --git a/multimedia/ffmpeg/Config.in b/multimedia/ffmpeg/Config.in
index e9413b0d2..1ba84e3d8 100644
--- a/multimedia/ffmpeg/Config.in
+++ b/multimedia/ffmpeg/Config.in
@@ -113,6 +113,7 @@ comment "External Libraries"
config FFMPEG_CUSTOM_SELECT_mp3lame
bool "MP3 LAME"
depends on FFMPEG_CUSTOM_PATENTED
+ depends on PACKAGE_lame-lib
select FFMPEG_CUSTOM_DECODER_mp3
select FFMPEG_CUSTOM_MUXER_mp3
select FFMPEG_CUSTOM_DEMUXER_mp3
@@ -124,8 +125,9 @@ config FFMPEG_CUSTOM_SELECT_speex
bool "Speex"
config FFMPEG_CUSTOM_SELECT_x264
- depends on FFMPEG_CUSTOM_PATENTED
bool "x264"
+ depends on FFMPEG_CUSTOM_PATENTED
+ depends on PACKAGE_libx264
select FFMPEG_CUSTOM_DECODER_h264
select FFMPEG_CUSTOM_MUXER_h264
select FFMPEG_CUSTOM_DEMUXER_h264
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index e79f5d630..03fe85ad8 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ffmpeg
PKG_VERSION:=2.8.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://ffmpeg.org/releases/
@@ -291,7 +291,8 @@ define Package/libffmpeg-custom
$(call Package/libffmpeg/Default)
TITLE+= (custom)
DEPENDS+= +FFMPEG_CUSTOM_SELECT_libopus:libopus +FFMPEG_CUSTOM_SELECT_speex:libspeex \
- +FFMPEG_CUSTOM_SELECT_x264:libx264 +FFMPEG_CUSTOM_SELECT_mp3lame:lame-lib
+ +PACKAGE_libx264:libx264 +PACKAGE_lame-lib:lame-lib
+
VARIANT:=custom
MENU:=1
endef
@@ -324,7 +325,7 @@ endef
define Package/libffmpeg-full
$(call Package/libffmpeg/Default)
TITLE+= (full)
- DEPENDS+= +alsa-lib +libx264 +lame-lib +libopus +libspeex
+ DEPENDS+= +alsa-lib +PACKAGE_libx264:libx264 +PACKAGE_lame-lib:lame-lib +libopus +libspeex
VARIANT:=full
endef
@@ -423,8 +424,8 @@ ifeq ($(BUILD_VARIANT),full)
FFMPEG_CONFIGURE+= \
--enable-libopus --enable-decoder=libopus \
--enable-libspeex --enable-decoder=libspeex \
- --enable-libx264 \
- --enable-libmp3lame
+ $(if $(CONFIG_PACKAGE_libx264),--enable-libx264) \
+ $(if $(CONFIG_PACKAGE_lame-lib),--enable-libmp3lame)
endif
ifeq ($(BUILD_VARIANT),custom)
@@ -468,12 +469,12 @@ endif
ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_x264),y)
FFMPEG_CONFIGURE+= \
- --enable-libx264 --enable-decoder=libx264
+ --enable-libx264
endif
ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_mp3lame),y)
FFMPEG_CONFIGURE+= \
- --enable-libmp3lame --enable-encoder=mp3
+ --enable-libmp3lame
endif
endif