aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2016-08-19 18:05:39 -0400
committerGitHub <noreply@github.com>2016-08-19 18:05:39 -0400
commitd875334e5e30412777814494b4a323f8a35e752e (patch)
treee16bd3725a9c39b56999cf6a6eed16b898407d82
parent6c91a16c6dfb1605ca356aa7665739d9e098af27 (diff)
parentf628fa9f831df393ef4c485dc8ade906499b83ba (diff)
Merge pull request #3082 from thess/libx264-merge
libx264: Fix build errors on x86 targets due to missing ASM features …
-rw-r--r--libs/libx264/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/libs/libx264/Makefile b/libs/libx264/Makefile
index b99e6bd74..3803808d7 100644
--- a/libs/libx264/Makefile
+++ b/libs/libx264/Makefile
@@ -24,9 +24,14 @@ PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
-TARGET_CFLAGS:=-Wno-maybe-uninitialized -Wshadow -Wall -std=gnu99 -fPIC -O3 -ffast-math -I.
+TARGET_CFLAGS+=-std=gnu99 -fPIC -O3 -ffast-math -I.
MAKE_FLAGS+= LD="$(TARGET_CC) -o"
+ifneq ($(CONFIG_TARGET_x86),)
+ CONFIGURE_VARS+= AS=yasm
+ MAKE_FLAGS+= AS=yasm
+endif
+
CONFIGURE_ARGS += \
--enable-shared \
--enable-pic \
@@ -40,7 +45,7 @@ define Package/libx264
SECTION:=libs
CATEGORY:=Libraries
TITLE:=H264/AVC free codec library.
- DEPENDS:=@BUILD_PATENTED
+ DEPENDS:=@BUILD_PATENTED @!TARGET_x86||YASM
URL:=http://www.videolan.org/developers/x264.html
endef