aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-10-08 18:54:00 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2018-10-08 18:54:00 -0300
commite4c24f0dc580aa36f4f35d0be5ac8fbefd5099cd (patch)
tree6e13a344dff7773f03e5a72d7ef2edc4c962266a
parent3b6e346a4c63f20cb9b55fc6b49077ca2e995770 (diff)
squid: update to version 4.3
Added some help to the choice of TLS library in menuconfig, taken from the squid release notes. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
-rw-r--r--net/squid/Config.in30
-rw-r--r--net/squid/Makefile9
2 files changed, 33 insertions, 6 deletions
diff --git a/net/squid/Config.in b/net/squid/Config.in
index d0a0db569..bcc072f18 100644
--- a/net/squid/Config.in
+++ b/net/squid/Config.in
@@ -45,9 +45,33 @@ if PACKAGE_squid
comment "Optional packages"
- config SQUID_use-gnutls
- bool "Use GnuTLS instead of OpenSSL"
- default n
+ choice
+ prompt "Choose SSL Library"
+ default SQUID_use-openssl
+
+ config SQUID_use-openssl
+ bool "Use OpenSSL (default)"
+
+ config SQUID_use-gnutls
+ bool "Use GnuTLS (experimental, see help)"
+ help
+ Use GnuTLS in place of OpenSSL for the core features of receiving
+ TLS connections from clients and making TLS connections to servers.
+ The GnuTLS support is still very much experimental and should be
+ tested before use.
+
+ SSL-Bump and certificate generation features are not yet supported
+ by GnuTLS builds. Nor are many other less commonly used Squid
+ TLS/SSL features.
+
+ squid.conf directives and configuration options which have undergone
+ name changes from 'ssl' to 'tls' prefix in Squid-4 have GnuTLS
+ support, unless explicitly stated otherwise.
+
+ Advanced configuration with specific selection of ciphers and
+ similar settings should still work, but needs the GnuTLS Priority
+ Strings instead of the OpenSSL options when using GnuTLS.
+ endchoice
config SQUID_with-libcap
bool "Use libcap - Linux capabilities library"
diff --git a/net/squid/Makefile b/net/squid/Makefile
index fcecb114a..ff6b0a0d1 100644
--- a/net/squid/Makefile
+++ b/net/squid/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=squid
-PKG_VERSION:=4.0.24
+PKG_VERSION:=4.3
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
@@ -18,10 +18,11 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www3.us.squid-cache.org/Versions/v4/ \
http://www2.pl.squid-cache.org/Versions/v4/ \
http://www.squid-cache.org/Versions/v4/
-PKG_HASH:=091da0d763307dcc0f5c784ab07ea0c5a093f6dfac60f17ff26e2a6d50f76a07
+PKG_HASH:=322612ef0544828f6c673a25124b32364fb41ef5e2847e21c89480b5546a4c7c
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
@@ -36,7 +37,7 @@ define Package/squid
$(call Package/squid/Default)
MENU:=1
DEPENDS:=+libpthread +librt +libltdl +libstdcpp +libatomic +USE_GLIBC:libbsd
- DEPENDS+= +SQUID_use-gnutls:libgnutls +!SQUID_use-gnutls:libopenssl
+ DEPENDS+= +SQUID_use-gnutls:libgnutls +SQUID_use-openssl:libopenssl
DEPENDS+= +SQUID_with-libcap:libcap
DEPENDS+= +SQUID_with-nettle:libnettle
DEPENDS+= +SQUID_with-expat:libexpat
@@ -66,6 +67,8 @@ define Package/squid-mod-cachemgr
endef
CONFIGURE_ARGS += \
+ BUILDCXX=$(HOSTCXX) \
+ BUILDCXXFLAGS=$(if $(HOST_CXXFLAGS),$(HOST_CXXFLAGS),-O2) \
--config-cache \
--datadir=/usr/share/squid \
--libexecdir=/usr/lib/squid \