aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2018-09-08 00:06:19 +0200
committerMichael Heimpold <mhei@heimpold.de>2018-09-08 00:11:51 +0200
commit3b6e346a4c63f20cb9b55fc6b49077ca2e995770 (patch)
treee72fff03d60e379f47fcfdaafbbc96577444dc79
parent5c8298f279f6533522aca0d2df68d27d59dab86d (diff)
php7: mod-intl: add optional dep for icu-full-data (fixes #6536)
As worked out, ICU library needs its data archive to be useful. Explain the situation in help text and add option to declare/prevent this dependency in package meta-data. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
-rw-r--r--lang/php7/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/lang/php7/Makefile b/lang/php7/Makefile
index 096c05f91..3e1827ce5 100644
--- a/lang/php7/Makefile
+++ b/lang/php7/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=7.2.9
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
@@ -150,6 +150,22 @@ define Package/php7-mod-gd/config
default y
endef
+define Package/php7-mod-intl/config
+ config PHP7_FULLICUDATA
+ bool "Add dependency to full ICU Data"
+ depends on PACKAGE_php7-mod-intl
+ default n
+endef
+
+define Package/php7-mod-intl/description
+ Note that this package depends in ICU library which is built without data
+ by default. This is to satisfy programs build and run dependencies but to
+ keep the installed footprint small on the target system(s).
+ However, the data is required to make the ICU library useful - and thus
+ directly affects PHPs ICU extension, too - so consider to also
+ select/install package 'icu-full-data'.
+endef
+
# not everything groks --disable-nls
DISABLE_NLS:=
@@ -611,7 +627,7 @@ $(eval $(call BuildModule,gmp,GMP,+PACKAGE_php7-mod-gmp:libgmp))
$(eval $(call BuildModule,hash,Hash))
$(eval $(call BuildModule,iconv,iConv,$(ICONV_DEPENDS)))
$(eval $(call BuildModule,imap,IMAP,+PACKAGE_php7-mod-imap:libopenssl +PACKAGE_libpam:libpam +PACKAGE_php7-mod-imap:uw-imap))
-$(eval $(call BuildModule,intl,Internationalization Functions,+PACKAGE_php7-mod-intl:icu))
+$(eval $(call BuildModule,intl,Internationalization Functions,+PACKAGE_php7-mod-intl:icu +PHP7_FULLICUDATA:icu-full-data))
$(eval $(call BuildModule,json,JSON))
$(eval $(call BuildModule,ldap,LDAP,+PACKAGE_php7-mod-ldap:libopenldap +PACKAGE_php7-mod-ldap:libsasl2))
$(eval $(call BuildModule,mbstring,MBString))