aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2017-04-02 20:39:30 +0200
committerGitHub <noreply@github.com>2017-04-02 20:39:30 +0200
commitbdd603b61c0e3f2ea4db235f697cadefb30a9066 (patch)
treea66b648007aeb797c45e0e96af3f4ccf187d8961
parent2e5deb62636c58a810e085d5d22f3ad71b098cab (diff)
parent6ecc58abcebe4e05b0e0933975182380c27bd7f9 (diff)
Merge pull request #4230 from ffainelli/unrar
unrar: Properly pass LDFLAGS
-rw-r--r--utils/unrar/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/utils/unrar/Makefile b/utils/unrar/Makefile
index 36d37b3db..b3b70f22f 100644
--- a/utils/unrar/Makefile
+++ b/utils/unrar/Makefile
@@ -58,6 +58,9 @@ define Package/libunrar/description
archives
endef
+MAKE_FLAGS += \
+ LDFLAGS="$(TARGET_LDFLAGS) -lpthread"
+
ifeq ($(BUILD_VARIANT),lib)
define Build/Compile
$(call Build/Compile/Default,lib)