aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-04-02 11:36:20 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-04-02 11:36:20 -0700
commit2e5deb62636c58a810e085d5d22f3ad71b098cab (patch)
tree36432429989ef2d92a2a63245d2df9465838e647
parentc275bd2bf4697e765d9bc73773f52efbc0bc24d0 (diff)
vsftpd: Pass TARGET_CPPFLAGS
Fixes build errors with external toolchains that don't have STAGING_DIR in their default search path for headers: mipsel-linux-gnu-gcc -c ssl.c -Os -pipe -mno-branch-likely -mips32r2 -mtune=24kc -fno-caller-saves -Wno-unused-result -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro -D_GNU_SOURCE -include fcntl.h -idirafter dummyinc ssl.c:28:25: fatal error: openssl/err.h: No such file or directory #include <openssl/err.h> ^ compilation terminated. Makefile:28: recipe for target 'ssl.o' failed make[3]: *** [ssl.o] Error 1 Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
-rw-r--r--net/vsftpd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/vsftpd/Makefile b/net/vsftpd/Makefile
index d85dc70e4..fa504d1b4 100644
--- a/net/vsftpd/Makefile
+++ b/net/vsftpd/Makefile
@@ -62,7 +62,7 @@ ifeq ($(BUILD_VARIANT),notls)
$(SED) 's/-lcrypt -lnsl/$(NLSSTRING)/' $(PKG_BUILD_DIR)/Makefile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
- CFLAGS="$(TARGET_CFLAGS)" \
+ CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
vsftpd
endef
@@ -75,7 +75,7 @@ ifeq ($(BUILD_VARIANT),tls)
$(SED) 's/-lcrypt -lnsl/$(NLSSTRING)/' $(PKG_BUILD_DIR)/Makefile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
- CFLAGS="$(TARGET_CFLAGS)" \
+ CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
vsftpd
endef