aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOthmar Truniger <github@truniger.ch>2015-03-11 23:33:42 +0100
committerOthmar Truniger <github@truniger.ch>2015-03-11 23:33:42 +0100
commit7ae9c98341a8134dd358b455bc6e37be52aa39a6 (patch)
tree2150f2df75c0acfcb94388675b90596cf6e167c1
parent58245f257fa6bc36a0887db5f4f381d41dbe52dc (diff)
libesmtp: streamline makefile
Signed-off-by: Othmar Truniger <github@truniger.ch>
-rw-r--r--libs/libesmtp/Makefile45
1 files changed, 17 insertions, 28 deletions
diff --git a/libs/libesmtp/Makefile b/libs/libesmtp/Makefile
index cd6269623..fa402c660 100644
--- a/libs/libesmtp/Makefile
+++ b/libs/libesmtp/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2014 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libesmtp
PKG_VERSION:=1.0.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MD5SUM:=c4fedc999b6c3820296b0eb92cc2e252
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
@@ -19,6 +19,9 @@ PKG_LICENSE_FILES:=COPYING
PKG_SOURCE_URL:=http://www.stafford.uklinux.net/libesmtp
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
include $(INCLUDE_DIR)/package.mk
define Package/libesmtp
@@ -29,38 +32,24 @@ define Package/libesmtp
DEPENDS:=+libpthread
endef
-define Build/Configure
- $(call Build/Configure/Default,--without-openssl)
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
-endef
+CONFIGURE_ARGS += \
+ --without-openssl
define Build/InstallDev
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/libesmtp.h $(STAGING_DIR)/usr/include/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/auth-client.h $(STAGING_DIR)/usr/include/
- $(CP) $(PKG_INSTALL_DIR)/usr/include/auth-plugin.h $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libesmtp.{a,so*} $(STAGING_DIR)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libesmtp-config $(1)/usr/bin/
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(1)/usr/bin/libesmtp-config
+
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libesmtp.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(2)/bin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libesmtp-config $(2)/bin/
- $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(2)/bin/libesmtp-config
-endef
-
-define Build/UninstallDev
- rm -rf \
- $(STAGING_DIR)/usr/include/libesmtp.h \
- $(STAGING_DIR)/usr/include/auth-client.h \
- $(STAGING_DIR)/usr/include/auth-plugin.h \
- $(STAGING_DIR)/usr/lib/libesmtp.{a,so*}
+ $(LN) ../../usr/bin/libesmtp-config $(2)/bin/
endef
define Package/libesmtp/install
- mkdir -p $(1)/usr/lib
+ $(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libesmtp.so.* $(1)/usr/lib/
endef