aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-03-11 10:35:45 +0100
committerSteven Barth <steven@midlink.org>2015-03-11 10:35:45 +0100
commit58245f257fa6bc36a0887db5f4f381d41dbe52dc (patch)
tree74edfe1cf075d7c7ec556d7dddebf313ff53ce4c
parent704e2f8d89c4093b00dbbe2d1fafff9d222fcf39 (diff)
parent9c5af1f29cac498f0c44a21d8bfcd6fdc2e25a04 (diff)
Merge pull request #1020 from commodo/python-updates
python: revert previous patch and add a filespec
-rw-r--r--lang/python/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 006ad64a6..e928a58a4 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -209,8 +209,8 @@ define PyPackage/python-base/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* $(1)/usr/lib/
endef
-# Dummy rule so that the package gets picked up
-define Package/python/install
+define PyPackage/python/filespec
+-|$(PYTHON_PKG_DIR)
endef
HOST_CFLAGS+= \
@@ -241,7 +241,7 @@ $(foreach package, $(PYTHON_PACKAGES), \
$(eval $(call PyPackage,python-base))
$(eval $(call PyPackage,python-light))
-#$(eval $(call PyPackage,python))
+$(eval $(call PyPackage,python))
$(eval $(call BuildPackage,python-base))
$(eval $(call BuildPackage,python-light))