aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-06-09 18:30:10 +0300
committerGitHub <noreply@github.com>2018-06-09 18:30:10 +0300
commit496068bef9a93d1aa90399eda5fcb6ffdaac26f2 (patch)
treefd8da7e4bbea11f155f5b8c3cc1cb773cdcd1a7f
parent269b4ce218ae9ab8329e7cbe4ee742705e3ca181 (diff)
parentb941c8d932315e88e96e46e24271d22a1ad71802 (diff)
Merge pull request #6164 from cotequeiroz/noddos_openssl-1.1
noddos: add compatibility with openssl 1.1
-rw-r--r--net/noddos/Makefile2
-rw-r--r--net/noddos/patches/010-openssl-1.1-fixes.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/net/noddos/Makefile b/net/noddos/Makefile
index a69c9fb2a..b066caee7 100644
--- a/net/noddos/Makefile
+++ b/net/noddos/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
# Name and release number of this package
PKG_NAME:=noddos
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPLv3
PKG_MAINTAINER:=Steven Hessing <steven.hessing@gmail.com>
diff --git a/net/noddos/patches/010-openssl-1.1-fixes.patch b/net/noddos/patches/010-openssl-1.1-fixes.patch
new file mode 100644
index 000000000..965e2b026
--- /dev/null
+++ b/net/noddos/patches/010-openssl-1.1-fixes.patch
@@ -0,0 +1,13 @@
+--- a/src/opensslfingerprint.cxx
++++ b/src/opensslfingerprint.cxx
+@@ -110,7 +110,9 @@ std::string getCertFingerprint(const std
+ snprintf(&fpbuf[57], 3, "%02x", md[19]);
+
+ if (Debug) {
+- syslog (LOG_DEBUG, "Cert: %s, fingerprint: %s", x->name, fpbuf);
++ char *namebuf = X509_NAME_oneline(X509_get_subject_name(x),NULL,0);
++ syslog (LOG_DEBUG, "Cert: %s, fingerprint: %s", namebuf, fpbuf);
++ free(namebuf);
+ }
+
+ std::string fp = fpbuf;