aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-29 16:42:31 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2018-05-29 16:42:31 -0300
commitb941c8d932315e88e96e46e24271d22a1ad71802 (patch)
tree74eb4b5a9e2772db5fa840f0e66ede2bcf818cef
parentd7ffa9ca0e1c344e162daaac1225a3d9a2da46a5 (diff)
noddos: add compatibility with openssl 1.1
Adapted minor piece of code to the new API. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
-rw-r--r--net/noddos/Makefile2
-rw-r--r--net/noddos/patches/010-openssl-1.1-fixes.patch13
2 files changed, 14 insertions, 1 deletions
diff --git a/net/noddos/Makefile b/net/noddos/Makefile
index a69c9fb2a..b066caee7 100644
--- a/net/noddos/Makefile
+++ b/net/noddos/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
# Name and release number of this package
PKG_NAME:=noddos
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPLv3
PKG_MAINTAINER:=Steven Hessing <steven.hessing@gmail.com>
diff --git a/net/noddos/patches/010-openssl-1.1-fixes.patch b/net/noddos/patches/010-openssl-1.1-fixes.patch
new file mode 100644
index 000000000..965e2b026
--- /dev/null
+++ b/net/noddos/patches/010-openssl-1.1-fixes.patch
@@ -0,0 +1,13 @@
+--- a/src/opensslfingerprint.cxx
++++ b/src/opensslfingerprint.cxx
+@@ -110,7 +110,9 @@ std::string getCertFingerprint(const std
+ snprintf(&fpbuf[57], 3, "%02x", md[19]);
+
+ if (Debug) {
+- syslog (LOG_DEBUG, "Cert: %s, fingerprint: %s", x->name, fpbuf);
++ char *namebuf = X509_NAME_oneline(X509_get_subject_name(x),NULL,0);
++ syslog (LOG_DEBUG, "Cert: %s, fingerprint: %s", namebuf, fpbuf);
++ free(namebuf);
+ }
+
+ std::string fp = fpbuf;