aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-25 00:46:48 -0700
committerGitHub <noreply@github.com>2019-04-25 00:46:48 -0700
commit2f5d0ba823d7693ccc4d6f2c41b81c25b7cde255 (patch)
tree20c7260142e9254c5b365cc43e9b4453bdeb8001
parent422af17bc7f85bc4878ed692740fc542fa9a0f7f (diff)
parent9cf412c0cba38f1251e9d8c1fd9afbb86caee88a (diff)
Merge pull request #8791 from MikePetullo/lighttpd
lighttpd: mark module configuration files
-rw-r--r--net/lighttpd/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/lighttpd/Makefile b/net/lighttpd/Makefile
index 750025963..d85610bbb 100644
--- a/net/lighttpd/Makefile
+++ b/net/lighttpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lighttpd
PKG_VERSION:=1.4.53
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
@@ -174,6 +174,10 @@ define BuildPlugin
TITLE:=$(2) module
endef
+ define Package/lighttpd-mod-$(1)/conffiles
+/etc/lighttpd/conf.d/$(4)-$(1).conf
+ endef
+
ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-$(1)),)
define Package/lighttpd-mod-$(1)/install
$(INSTALL_DIR) $$(1)/usr/lib/lighttpd