aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2019-04-24 15:57:34 -0400
committerW. Michael Petullo <mike@flyn.org>2019-04-24 15:57:34 -0400
commit9cf412c0cba38f1251e9d8c1fd9afbb86caee88a (patch)
treea3712ea35c090f4759bfc8722247a7c017d3fa54
parentc06badc4c55ffa5a18813b6e1347f8fc511ea2a1 (diff)
lighttpd: mark module configuration files
Signed-off-by: W. Michael Petullo <mike@flyn.org>
-rw-r--r--net/lighttpd/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/lighttpd/Makefile b/net/lighttpd/Makefile
index 750025963..d85610bbb 100644
--- a/net/lighttpd/Makefile
+++ b/net/lighttpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lighttpd
PKG_VERSION:=1.4.53
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
@@ -174,6 +174,10 @@ define BuildPlugin
TITLE:=$(2) module
endef
+ define Package/lighttpd-mod-$(1)/conffiles
+/etc/lighttpd/conf.d/$(4)-$(1).conf
+ endef
+
ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-$(1)),)
define Package/lighttpd-mod-$(1)/install
$(INSTALL_DIR) $$(1)/usr/lib/lighttpd