aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Stadler <peter.stadler@student.uibk.ac.at>2020-01-28 21:31:58 +0100
committerPeter Stadler <peter.stadler@student.uibk.ac.at>2020-01-30 17:10:16 +0100
commit29f288fda914477cc6fd12826bd430b6d1420b70 (patch)
tree128d702f7c9dba07ff45ce72a1a42a5909cb58f2
parent9aeb5cfbd402602f747477b3818edf73d11772e7 (diff)
python3-asgiref: add package to fix django
Django 3 has this package as dependency. Signed-off-by: Peter Stadler <peter.stadler@student.uibk.ac.at>
-rw-r--r--lang/python/django/Makefile4
-rw-r--r--lang/python/python3-asgiref/Makefile35
2 files changed, 37 insertions, 2 deletions
diff --git a/lang/python/django/Makefile b/lang/python/django/Makefile
index d06e7907e..063e916e8 100644
--- a/lang/python/django/Makefile
+++ b/lang/python/django/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=django
PKG_VERSION:=3.0.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=Django
PKG_HASH:=8c3575f81e11390893860d97e1e0154c47512f180ea55bd84ce8fa69ba8051ca
@@ -34,7 +34,7 @@ endef
define Package/python3-django
$(call Package/django/Default)
- DEPENDS:= +python3 +python3-pytz +python3-sqlparse
+ DEPENDS:= +python3 +python3-pytz +python3-sqlparse +python3-asgiref
VARIANT:=python3
endef
diff --git a/lang/python/python3-asgiref/Makefile b/lang/python/python3-asgiref/Makefile
new file mode 100644
index 000000000..60548e66a
--- /dev/null
+++ b/lang/python/python3-asgiref/Makefile
@@ -0,0 +1,35 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=asgiref
+PKG_VERSION:=3.2.3
+PKG_RELEASE:=1
+
+PYPI_NAME:=asgiref
+PKG_HASH:=7e06d934a7718bf3975acbf87780ba678957b87c7adc056f13b6215d610695a0
+
+PKG_MAINTAINER:=Peter Stadler <peter.stadler@student.uibk.ac.at>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-asgiref
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Standard for Python asynchronous web apps and servers.
+ URL:=https://asgi.readthedocs.io/en/latest/
+ DEPENDS:=+python3-light +python3-logging +python3-asyncio
+ VARIANT:=python3
+endef
+
+define Package/python3-asgiref/description
+ ASGI is a standard for Python asynchronous web apps and servers to communicate
+ with each other, and positioned as an asynchronous successor to WSGI.
+endef
+
+$(eval $(call Py3Package,python3-asgiref))
+$(eval $(call BuildPackage,python3-asgiref))
+$(eval $(call BuildPackage,python3-asgiref-src))