aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-01-30 15:05:33 +0200
committerDaniel Golle <daniel@makrotopia.org>2020-01-30 15:06:46 +0200
commit9aeb5cfbd402602f747477b3818edf73d11772e7 (patch)
treead027d60d4458b715949c28a5b5f8af52bb228c8
parentab3ba9ff2bf0768096c7a31742f108e71e533b86 (diff)
python-libmodbus: add package
Python Interface for libmodbus written with CFFI. This libmodbus wrapper is compatible with Python 2 and Python 3. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--lang/python/python-libmodbus/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/lang/python/python-libmodbus/Makefile b/lang/python/python-libmodbus/Makefile
new file mode 100644
index 000000000..c503b76eb
--- /dev/null
+++ b/lang/python/python-libmodbus/Makefile
@@ -0,0 +1,58 @@
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=python-libmodbus
+PKG_VERSION:=0.0.2
+PKG_RELEASE:=1
+
+PKG_LICENSE:=BSD-3-Clause
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
+
+PYPI_NAME:=pylibmodbus
+PKG_HASH:=c6d72f291426758b546cc88a1cdf85c33afa6011192a5d88a5117d44814ffc0e
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python-package.mk
+include ../python3-package.mk
+
+define Package/python-libmodbus/Default
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ URL:=https://github.com/stephane/pylibmodbus
+endef
+
+define Package/python-libmodbus
+$(call Package/python-libmodbus/Default)
+ TITLE:=python-libmodbus
+ DEPENDS:=+libmodbus \
+ +PACKAGE_python-libmodbus:python-light \
+ +PACKAGE_python-libmodbus:python-ctypes
+ VARIANT:=python
+endef
+
+define Package/python3-libmodbus
+$(call Package/python-libmodbus/Default)
+ TITLE:=pylibmodbus
+ DEPENDS:=+libmodbus \
+ +PACKAGE_python3-libmodbus:python-light \
+ +PACKAGE_python3-libmodbus:python-ctypes
+ VARIANT:=python3
+endef
+
+define Package/python-libmodbus/description
+ Python Interface for libmodbus written with CFFI.
+endef
+
+define Package/python3-libmodbus/description
+$(call Package/python-libmodbus/description)
+.
+(Variant for Python3)
+endef
+
+$(eval $(call PyPackage,python-libmodbus))
+$(eval $(call BuildPackage,python-libmodbus))
+
+$(eval $(call Py3Package,python3-libmodbus))
+$(eval $(call BuildPackage,python3-libmodbus))