aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-04-19 14:10:45 +0300
committerRosen Penev <rosenp@gmail.com>2024-04-19 14:19:25 -0700
commit2650de46866572f110c28b5a3ddff5ee86c59f45 (patch)
tree6b4ffde74a7338250c946e13670b529bd21e6881
parentbfb5d820bf3f7e50fdde9da759e7407b5d5763a2 (diff)
socat: fix compile error when ccache is enabled
Signed-off-by: krant <aleksey.vasilenko@gmail.com>
-rw-r--r--net/socat/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 6da3aee46..4afaf7e78 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=socat
PKG_VERSION:=1.8.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
@@ -58,6 +58,9 @@ CONFIGURE_ARGS += \
--disable-readline \
--enable-termios
+## procan.c fails to compile when ccache is enabled
+MAKE_FLAGS += CC="$(TARGET_CC_NOCACHE)"
+
ifneq ($(CONFIG_SOCAT_SSL),y)
CONFIGURE_ARGS+= --disable-openssl
endif