aboutsummaryrefslogtreecommitdiff
path: root/net/socat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/socat/Makefile')
-rw-r--r--net/socat/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 6da3aee46..4afaf7e78 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=socat
PKG_VERSION:=1.8.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
@@ -58,6 +58,9 @@ CONFIGURE_ARGS += \
--disable-readline \
--enable-termios
+## procan.c fails to compile when ccache is enabled
+MAKE_FLAGS += CC="$(TARGET_CC_NOCACHE)"
+
ifneq ($(CONFIG_SOCAT_SSL),y)
CONFIGURE_ARGS+= --disable-openssl
endif