aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a0d6512..33ec531 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -34,6 +34,10 @@ if DISABLE_ASSERTS
ptunnel_ng_CFLAGS += -DNDEBUG=1
endif
+if ENABLE_SANITIZER
+ptunnel_ng_CFLAGS += -fsanitize=address -fsanitize=leak -fsanitize=undefined
+endif
+
ptunnel_ng_SOURCES = \
md5.c \
challenge.c \