aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..b51bad2
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,18 @@
+bin_PROGRAMS = ptunnel
+
+ptunnel_CFLAGS = -Wall
+if HAVE_PCAP
+ptunnel_CFLAGS += -DHAVE_PCAP=1
+endif
+if HAVE_SELINUX
+ptunnel_CFLAGS += -DHAVE_SELINUX=1
+endif
+
+ptunnel_SOURCES = \
+ md5.c \
+ challenge.c \
+ options.c \
+ utils.c \
+ pkt.c \
+ pdesc.c \
+ ptunnel.c