aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 35 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f45d875..eeb6634 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_PREREQ(2.69)
-AC_INIT([ptunnel-ng], [1.31], [], [], [])
+AC_INIT([ptunnel-ng], [1.32], [], [], [])
AC_CONFIG_SRCDIR([src/config.h.in])
AC_CONFIG_FILES([Makefile src/Makefile])
@@ -145,6 +145,18 @@ if test x"${pcap_enabled}" != x -a \
[pcap_enabled=])
fi
+dnl Check for more secure randomization functions
+AC_CHECK_HEADERS([bsd/stdlib.h],, [random_enabled=yes])
+AC_SEARCH_LIBS([arc4random], [bsd],,,)
+AC_CHECK_FUNCS([arc4random], [random_enabled=],)
+if test x"${random_enabled}" != x; then
+ AC_CHECK_FUNCS([timespec_get srandom random],
+ [random_enabled=yes],
+ [random_enabled=])
+else
+ arc4random_enabled=yes
+fi
+
dnl Check for SELINUX
if test x"${selinux_enabled}" != x; then
AC_CHECK_HEADERS([selinux/selinux.h],,
@@ -152,6 +164,25 @@ if test x"${selinux_enabled}" != x; then
AC_SEARCH_LIBS([setcon], [selinux],,[selinux_enabled=],)
fi
+dnl Check for ICMP_FILTER
+AC_MSG_CHECKING([for working ICMP_FILTER])
+AC_COMPILE_IFELSE(
+[AC_LANG_PROGRAM([[
+#include <netinet/in.h>
+#include <sys/socket.h>
+#include <linux/icmp.h>
+void foo() {
+ struct icmp_filter filt;
+ int sockfd = socket(AF_INET, SOCK_RAW, IPPROTO_ICMP);
+ filt.data = ~((1<<ICMP_ECHO) | (1<<ICMP_ECHOREPLY));
+ setsockopt(sockfd, SOL_RAW, ICMP_FILTER, &filt, sizeof filt);
+}
+]], [])]
+,[AC_MSG_RESULT([yes])
+ with_icmp_filter="yes"]
+,[AC_MSG_RESULT([no])
+ with_icmp_filter="no"])
+
dnl Check for Android liblog.so
AC_SEARCH_LIBS([__android_log_vprint], [log],,,)
@@ -159,6 +190,9 @@ dnl Set automake conf vars
AM_CONDITIONAL([HAVE_PCAP], [test x"${pcap_enabled}" = xyes])
AM_CONDITIONAL([HAVE_SELINUX], [test x"${selinux_enabled}" = xyes])
AM_CONDITIONAL([IS_WINDOWS], [test x"${use_msw}" = xyes])
+AM_CONDITIONAL([HAVE_ICMPFILTER], [test x"${with_icmp_filter}" = xyes])
+AM_CONDITIONAL([HAVE_RANDOM], [test x"${random_enabled}" = xyes])
+AM_CONDITIONAL([HAVE_ARC4RANDOM], [test x"${arc4random_enabled}" = xyes])
dnl output config headers
AC_CONFIG_HEADERS([src/config.h:src/config.h.in])