aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2019-09-11 20:42:18 +0200
committerToni Uhlig <matzeton@googlemail.com>2019-09-11 20:43:18 +0200
commit6c8c121cc15932e97dafd11c841078addfeee195 (patch)
treeae357e661e78e458bf2b82a1e45dabaa889998bd /src/Makefile.am
parentca2b3b512b319acd604cb700f40e138dbb4b8be6 (diff)
configure.ac: enable assertions explicitly
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6f9ca23..a0d6512 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -30,6 +30,10 @@ if USE_CUSTOMRNG
ptunnel_ng_CFLAGS += -DUSE_CUSTOMRNG=1
endif
+if DISABLE_ASSERTS
+ptunnel_ng_CFLAGS += -DNDEBUG=1
+endif
+
ptunnel_ng_SOURCES = \
md5.c \
challenge.c \