aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2018-07-15 01:51:34 +0200
committerToni Uhlig <matzeton@googlemail.com>2018-07-15 01:51:34 +0200
commita5b0af10914a4724c17e8c309a31c8e4380996d7 (patch)
treea46d62f0be7909a6066efc7843fe9dd51e472785 /PKGBUILD
parentc537fe4dbe31b68e2276e515424ef9fc9c6fb70a (diff)
parentfe77689ea1b17cd02564bf58b15cc1c75184992f (diff)
Merge branch 'master' into release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..2e4186a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname="ptunnel-ng"
+pkgver=1.1
+pkgrel=1
+pkgdesc="PingTunnel-NG binary for icmp/udp tunneling"
+arch=('i686' 'x86_64')
+url='https://www.github.com/lnslbrty/ptunnel-ng'
+license=('BSD-3')
+makedepends=('git')
+provides=("ptunnel-ng=${pkgver}")
+source=("https://github.com/lnslbrty/ptunnel-ng/archive/v${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --disable-pcap \
+ --disable-selinux
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}" -type d -name .git -exec rm -r '{}' +
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/ptunnel-ng/LICENSE"
+}