aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2018-07-19 00:21:02 +0200
committerToni Uhlig <matzeton@googlemail.com>2018-07-19 00:21:02 +0200
commitaa3e837123dc576967a024126bef351b68ba33e5 (patch)
tree9abd6e797c57f435ae253cbf3711c8b582925f0b /PKGBUILD
parentb678e84c542862811059cf9c2974f7f2aed0914b (diff)
parentd83e11d86a24c4dd9bf8f09de57d7c1377c15eea (diff)
Merge branch 'master' of ssh://git.lan:/git/potd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..b7a692d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=potd
+pkgver=c19cb7e39a80fab15429da599d7b8c85224fde96
+pkgrel=1
+pkgdesc="A hgih scalable SSH/TCP honeypot."
+arch=('i686' 'x86_64')
+url="https://github.com/lnslbrty/potd"
+license=('BSD-3')
+depends=('libssh' 'libseccomp')
+source=('https://github.com/lnslbrty/potd/archive/c19cb7e39a80fab15429da599d7b8c85224fde96.zip')
+md5sums=('5b2619cc88f2a8c117029880de10ffcf')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR=$pkgdir install
+}