summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorToni Uhlig <matzeton@googlemail.com>2023-07-09 10:52:21 +0200
committerToni Uhlig <matzeton@googlemail.com>2023-07-10 10:52:21 +0200
commit84a337ae0a4b8f60220ac08d04222bbaff6143d0 (patch)
treea078350200483786002cdcd6258a7979809ba87e /CMakeLists.txt
parentfebaef00017278ac65cb7e285564ebc9d5dadfe5 (diff)
MVP
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt60
1 files changed, 51 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d462a4..2df0801 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,14 +9,52 @@ set(CMAKE_AUTORCC ON)
set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
-find_package(QT NAMES Qt6 Qt5 REQUIRED COMPONENTS Widgets)
-find_package(Qt${QT_VERSION_MAJOR} REQUIRED COMPONENTS Widgets)
+include(ExternalProject)
+
+find_package(QT NAMES Qt6 REQUIRED COMPONENTS Core Widgets)
+find_package(Qt${QT_VERSION_MAJOR} REQUIRED COMPONENTS Core Widgets)
+find_library(PCAP_LIBRARY NAMES pcap wpcap)
+
+set_property(SOURCE qhexedit2_init.cpp PROPERTY SKIP_AUTOGEN ON)
+
+qt_add_plugin(qhexedit2
+ STATIC
+ qhexedit2/src/chunks.cpp
+ qhexedit2/src/chunks.h
+ qhexedit2/src/commands.cpp
+ qhexedit2/src/commands.h
+ qhexedit2/src/qhexedit.cpp
+ qhexedit2/src/qhexedit.h
+ qhexedit2/src/QHexEditPlugin.cpp
+ qhexedit2/src/QHexEditPlugin.h
+)
+
+ExternalProject_Add(PcapPlusPlus SOURCE_DIR ${CMAKE_SOURCE_DIR}/PcapPlusPlus
+ CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${CMAKE_BINARY_DIR}/ppp-install
+ -DBUILD_SHARED_LIBS=OFF -DPCAPPP_BUILD_COVERAGE=OFF
+ -DPCAPPP_BUILD_EXAMPLES=OFF -DPCAPPP_BUILD_TESTS=OFF)
+
+option(ENABLE_SANITIZER "Enable ASAN/LSAN/UBSAN." OFF)
+if(ENABLE_SANITIZER)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fsanitize=address -fsanitize=undefined -fno-sanitize=alignment -fsanitize=enum -fsanitize=leak")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fsanitize=address -fsanitize=undefined -fno-sanitize=alignment -fsanitize=enum -fsanitize=leak")
+endif()
set(PROJECT_SOURCES
main.cpp
mainwindow.cpp
mainwindow.h
mainwindow.ui
+
+ pcapplusplus.cpp
+ pcapplusplus.h
+
+ qhexedit2/src/chunks.cpp
+ qhexedit2/src/chunks.h
+ qhexedit2/src/commands.cpp
+ qhexedit2/src/commands.h
+ qhexedit2/src/qhexedit.cpp
+ qhexedit2/src/qhexedit.h
)
if(${QT_VERSION_MAJOR} GREATER_EQUAL 6)
@@ -24,17 +62,12 @@ if(${QT_VERSION_MAJOR} GREATER_EQUAL 6)
MANUAL_FINALIZATION
${PROJECT_SOURCES}
)
-# Define target properties for Android with Qt 6 as:
-# set_property(TARGET pcap-editor APPEND PROPERTY QT_ANDROID_PACKAGE_SOURCE_DIR
-# ${CMAKE_CURRENT_SOURCE_DIR}/android)
-# For more information, see https://doc.qt.io/qt-6/qt-add-executable.html#target-creation
+ qt_import_plugins(pcap-editor INCLUDE qhexedit2)
else()
if(ANDROID)
add_library(pcap-editor SHARED
${PROJECT_SOURCES}
)
-# Define properties for Android with Qt 5 after find_package() calls as:
-# set(ANDROID_PACKAGE_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/android")
else()
add_executable(pcap-editor
${PROJECT_SOURCES}
@@ -42,7 +75,14 @@ else()
endif()
endif()
-target_link_libraries(pcap-editor PRIVATE Qt${QT_VERSION_MAJOR}::Widgets)
+add_dependencies(pcap-editor PcapPlusPlus)
+
+target_include_directories(pcap-editor PRIVATE ${CMAKE_BINARY_DIR}/ppp-install/include/pcapplusplus)
+target_link_libraries(pcap-editor PRIVATE Qt${QT_VERSION_MAJOR}::Widgets
+ ${CMAKE_BINARY_DIR}/ppp-install/lib/libPcap++.a
+ ${CMAKE_BINARY_DIR}/ppp-install/lib/libPacket++.a
+ ${CMAKE_BINARY_DIR}/ppp-install/lib/libCommon++.a
+ ${PCAP_LIBRARY})
set_target_properties(pcap-editor PROPERTIES
MACOSX_BUNDLE_GUI_IDENTIFIER my.example.com
@@ -59,3 +99,5 @@ install(TARGETS pcap-editor
if(QT_VERSION_MAJOR EQUAL 6)
qt_finalize_executable(pcap-editor)
endif()
+
+message(STATUS "QT_DIR: ${QT_DIR}")